Instalación de Raptorcache 2

Instalar Raptor

Raptorcache para CD Descargar
Raptorcache para USB Descargar (Para grabar la imagen a la memoria USB puede usar el programa Win32 Disk Imager)

 

Redirección y priorización de tráfico Mikrotik por Mangle (modificar “in-interface” por el nombre de su interface en la regla mark-routing)

/ip firewall filter
add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/30
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=raptor_route scope=30 target-scope=10
/ip firewall mangle
add action=mark-routing chain=prerouting comment="Raptor - Mangle ====================" disabled=no dst-port=80 in-interface=LAN new-routing-mark=raptor_route passthrough=no protocol=tcp
add action=mark-connection chain=forward comment="== RAPTORCACHE ==" content="X-Cache-Raptor: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=raptor-connection disabled=no new-packet-mark=raptor-packs passthrough=no

Para la versión de Mikrotik 5.x la priorización y liberación del Full Caché se hace en queue tree, con las siguientes reglas

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="RaptorCache" packet-mark=raptor-packs parent=global-out priority=4 queue=default

Para la versión de Mikrotik 6.x la priorización y liberación del Full Caché se hace en queue simple, con las siguientes reglas

/queue simple
add max-limit=30M/30M name=RaptorCache packet-marks=raptor-packs queue=default-small/pcq-download target="" total-queue=default

En el caso que tengan configurado como Hotspot o PPPoE en la versión de Mikrotik 6.x, pueden adicionar un script para que mantenga la regla de queues en primer lugar.

/system script
add name=RaptorCache policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source=\
"/queue simple move [find name=\"RaptorCache\"] [:pick [find] 0]"

Y luego a cuanto tiempo se ejecutará el script, en la regla pondremos que se ejecute a cada 10 segundos

/system scheduler
add disabled=no interval=10s name=RaptorCache on-event="/system script run RaptorCache" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=oct/11/2013 start-time=08:00:00

Activar las reglas de firewall en el servidor Raptor

Por ej. si “192.168.1.0/24” es el segmento de red de los usuarios y “eth0” es el nombre de la interface del servidor Raptor

 

En el caso se tenga varios segmentos de red de usuarios

 

Luego Reiniciar el Firewall

 
TOP